1. If you've come here looking to find out how to play/install PropHunt, simply open TF2 and join our server gamingmasters.org:27019
    And stick around because you're here already and there is no escape.
    Dismiss Notice

How to install PropHunt ?

Discussion in 'PropHunt' started by STARDUST, 25 Oct 2010.

  1. STARDUST New Member

    I've seen another topic regarding this, however there weren't any answers that could actually solve my problem.

    So, as i said in my introduction topic, my community recently got sponsored, and seeing we have been given a tf2 server, it would be kickass to get prophunt running on it.

    So, i've went to alliedmodders @ https://forums.alliedmods.net/showthread.php?t=107104&highlight=TF2
    and downloaded the 4 files

    • SDK Hooks (Link)
    • PropHunt Resources Pack (Link)
    • PropHunt Data Pack (Link)
    • prophunt.smx (Link)
    Seeing they say it's all self-explanatory, i just dragged the files over with my FTP onto the server.

    Now the thing is, when having done that, i'm kinda clueless on WHAT files i need to EDIT to make the prophunt mod work :s

    I've editted my server.cfg with 2 lines :

    mp_idledealmethod 0
    ph_enable 1

    But sadly whenever i start the server it doesnt run anything.
    I also noticed when having changed my command line (just changed the default map) somehow it makes the server name line into the default one aswell, even tho our server.cfg has our community server name in it.

    I hope there is someone who would want to help me out, but then in a detailed way, so all new people who are about to install the mod, and that would have problems, could simply follow this post.

    if it's too much to talk about here, just add me on steam: flemishpatriot, i could even set u up with a quick subuser account .

    Thanks in advance,

    Last edited by a moderator: 27 Nov 2013
  2. gRiMrEaPeRsco Thunder ... wait for it ... Penis

    Have you tried switching it off and on again?
  3. STARDUST New Member

    Wow , fast reply
    uhm well yes and no, i tried it, but the command doesnt get recognised :s
  4. STARDUST New Member

    Little update:

    from what ive seen in other little related post:

    // Server Name
    hostname " CORE^ Hide&Seek [FASTDL] | core-gaming.org | sponsored by PPP !"
    // RCON Passsword
    rcon_password "*****"
    // Server Password
    sv_password "prophuntwontwork"
    // Bandwidth Rates/Settings
    // Advanced Users Only!
    sv_maxrate 30000
    sv_minrate 25000
    sv_maxupdaterate 101
    sv_minupdaterate 100
    sv_maxcmdrate 101
    sv_mincmdrate 100
    sv_unlag 1
    sv_maxunlag .5
    ph_enable 1
    ph_propmenu 0
    mp_idledealmethod 0
    sv_downloadurl "http://www.core-gaming.org/Games/tf"
    sv_allowdownload 1
    sv_allowupload 1
    // Execute Ban Files
    exec banned_user.cfg
    exec banned_ip.cfg 


    maxplayers 18 // Team sizes are derived from maxplayers.
     Each arena match has 3 teams, two playing and one waiting in the queue.
    So maxplayers 18 will give you a max team size of 6 (18/3).
    hostname " CORE^ Hide&Seek [FASTDL] | core-gaming.org | sponsored by PPP !"
    mapcyclefile "arena_mapcycle.txt"
    mp_waitingforplayers_cancel 1
    mp_waitingforplayers_restart 1 

    Still, whenever i change to an arena map that came with the resource pack, it won't load the plugin.
    What i did notice is that the cfg's in the prophunt folder linked to the maps dont have the same name.


    First img is in the folder:tf/addons/sourcemod/data/prophunt
    second in the folder maps obviously
  5. Geit Coding wizard!

    If you RCON "sm plugins reload prophunt" or "sm plugins load prophunt" when on an arena map, are there any error messages? (I don't mean the "PropHunt is already loaded" error)
  6. STARDUST New Member


    [SM] Plugin prophunt.smx failed to load: Required extension "sdkhooks" file("sdkhooks.ext") not running.
    i'm pretty sure i did install sdkhooks :s
    lemme get back on that

    edit2: yup the files are in the right folders..
  7. Geit Coding wizard!

    sm exts load sdkhooks (iirc) - Any errors returned?
  8. STARDUST New Member

    so simply this in console?
    sm exts load sdkhooks (iirc)

    SourceMod 1.3.5, by AlliedModders LLC
    To see running plugins, type "sm plugins"
    Visit http://www.sourcemod.net/
    To see credits, type "sm credits"

    I'm sorry if i'm doing something wrong lol :$
  9. Geit Coding wizard!

    just "sm exts load sdkhooks"
  10. STARDUST New Member

    It gives the same thing :(
  11. Geit Coding wizard!

    You are RCON-ing it Right?
  12. STARDUST New Member

    yeah, i am

    ] rcon_password ***********
    ] "sm exts load sdkhooks"
    To see running plugins, type "sm plugins"
    SourceMod 1.3.5, by AlliedModders LLC
    To see credits, type "sm credits"
    Visit http://www.sourcemod.net/
  13. Geit Coding wizard!

    1st, Get rid of the quotation marks - 2nd you need to prefix rcon to anything your trying to rcon... So the full command would be "rcon sm exts load sdkhooks" minus quotation marks
  14. STARDUST New Member

    allright, my bad

    ] rcon sm exts load sdkhooks
    [SM] Loaded extension sdkhooks.ext.dll successfully.
  15. Geit Coding wizard!

    Now try to run prophunt after doing that - If it works, you need to add an autoload file for SDKHooks. If it doesn't, you need to look at your sourcemod error/fatal log and work out why it isn't loading.
  16. STARDUST New Member

    ] rcon sm exts load sdkhooks
    [SM] Loaded extension sdkhooks.ext.dll successfully.
    autokick is disabled for STARDUST @ www.core-gaming.org
    ] rcon sm plugins load prophunt
    [SM] Plugin prophunt.smx failed to load: Required extension "sdkhooks" file("sdkhooks.ext") not running.
    lol fail :(

    and the error log doesnt give away anything special :s

  17. Geit Coding wizard!

    Try updating sourcemod to 1.4dev and reinstalling SDKHooks and see if that changes anything.
  18. STARDUST New Member

    hmm, so i downloaded http://www.sourcemod.net/smdrop/1.4/sourcemod-1.4.0-hg3142-windows.zip
    and uploaded it, overwritten all files, but it stays at 1.3.5...
    God why doesnt it do what it is suposed to do -_-

    all the plugins are 1.4... but the version is 1.3.5

    edit: i'm currently deleting sourcemod and reinstalling it
  19. STARDUST New Member

    ok, its at 1.4 dev, but have same problem :(
    sdkhooks will load, but then when i try to load prophunt, it sais sdkhooks isnt loaded...

    would u mind adding me on steam?
  20. STARDUST New Member

    U know, when downloading stuff like the sdkhooks, it should be more obvious which one u actually need....
    i downloaded the wrong version for the wrong game...

    It's working now altho it still makes me wait untill another player joins

Users Viewing Thread (Users: 0, Guests: 0)

Users found this page by searching for:

  1. how to install prop hunt

  2. how to get prop hunt

  3. how to download prop hunt

  4. how to install prophunt,
  5. install prop hunt,
  6. prop hunt install,
  7. prop hunt requirements,
  8. installing prop hunt,
  9. how to instal prop hunt,
  10. Required extension sdkhooks file(sdkhooks.ext) not running